AML Screening Lists unable to show new search results

Incident Report for ACA ComplianceAlpha

Resolved

This incident has been resolved.
Posted Apr 30, 2025 - 08:37 EDT

Investigating

We are currently investigating an issue where we are failing to load data from a third-party data provider. We will provide an update when we have more information.
Posted Apr 29, 2025 - 13:33 EDT
This incident affected: ComplianceAlpha (AML KYC / CIP Solution).