Select Tenant Error

Incident Report for ACA ComplianceAlpha

Resolved

The issue with users associated with multiple tenants having difficulty accessing their respective tenants has been resolved.
Posted May 09, 2024 - 16:24 EDT

Investigating

Users associated with multiple tenants are having difficulty accessing their respective tenants.
Posted May 09, 2024 - 15:39 EDT
This incident affected: ComplianceAlpha (ComplianceAlpha Login, ComplianceAlpha Single Sign-On (SSO)).