Slowness-Transactions

Incident Report for ACA ComplianceAlpha

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 11:17 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 10:46 EDT

Identified

The fix addressing the slow grid/page loading issue in Employee Compliance is currently undergoing final testing and is expected to be released today, October 7th.
Posted Oct 07, 2025 - 09:30 EDT

Investigating

There are currently reports of slowness on the Employee Compliance Transaction page. The issue is actively being investigated. Further updates will be provided as they become available.
Posted Oct 06, 2025 - 11:51 EDT
This incident affected: ComplianceAlpha (Employee Compliance Solution).