Marketing Review (MR) - Slowness loading business groups/affiliates
Incident Report for ACA ComplianceAlpha
Resolved
This incident has been resolved. Business Groups and Affiliates are now loading without delays.
Posted Apr 04, 2023 - 13:10 EDT
Monitoring
The issues have been resolved and we are currently monitoring performance.
Posted Apr 04, 2023 - 11:48 EDT
Identified
The issue has been identified and we are working towards a resolution with an ETA of 1pm EST.
Posted Apr 04, 2023 - 11:36 EDT
Investigating
Our team is investigating reports of slowness when loading Business Groups and Affiliates in the Marketing Review Module which may be causing slowness when creating submissions.
Posted Apr 04, 2023 - 09:59 EDT
This incident affected: ComplianceAlpha (Marketing Review Solution).