Security Searches
Incident Report for ACA ComplianceAlpha
Resolved
This incident has been resolved.
Posted Oct 26, 2023 - 09:52 EDT
Monitoring
As of 25-Oct-2023, 15:15 EDT (19:15 UTC), all service has been restored.
Posted Oct 25, 2023 - 15:29 EDT
Investigating
The functionality of the account security search feature is presently experiencing an issue and is under investigation.
Posted Oct 25, 2023 - 14:14 EDT
This incident affected: ComplianceAlpha (Employee Compliance Solution).