EC - Certification Loading Slow
Incident Report for ACA ComplianceAlpha
Resolved
This incident has been resolved.
Posted Aug 02, 2024 - 17:00 EDT
Identified
The solution for the slow loading of Employee Compliance Certifications has been identified and will be deployed to production tonight (August 2, 2024) at 9:00 pm ET.
Posted Aug 02, 2024 - 11:49 EDT
Investigating
We are investigating an issue causing the Employee Compliance Certification page to load slowly.
Posted Aug 02, 2024 - 11:28 EDT
This incident affected: ComplianceAlpha (Employee Compliance Solution).