MR Submissions
Incident Report for ACA ComplianceAlpha
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 16:58 EDT
Investigating
The Submission page within Market Review (MR) is not loading promptly. Until this issue is resolved, you can work around it by filtering the search Submission tab by affiliate or business group.
Posted Jun 03, 2024 - 13:50 EDT
This incident affected: ComplianceAlpha (Marketing Review Solution).