Employee Compliance - Certifications

Incident Report for ACA ComplianceAlpha

Resolved

We're closely monitoring the situation, but this issue should now be mostly resolved. It is expected to be fully resolved and back to working capacity. We'll update again if otherwise.
Posted Jul 01, 2025 - 18:00 EDT

Update

The investigation into the degraded performance and Certifications continues with urgency; any erroneously duplicated certifications have been removed. A further update will be posted in due course
Posted Jul 01, 2025 - 11:36 EDT

Investigating

We are currently investigating all the issues related to Certifications in Employee Compliance.
Posted Jul 01, 2025 - 09:11 EDT
This incident affected: ComplianceAlpha (Employee Compliance Solution).