Marketing Review Submissions Not Loading

Incident Report for ACA ComplianceAlpha

Resolved

A hotfix has been released and the issue is now resolved.
Posted Aug 26, 2024 - 16:51 EDT

Investigating

We are currently investigating an issue where submissions are not fully loading in the Marketing Review module.
Posted Aug 26, 2024 - 15:19 EDT
This incident affected: ComplianceAlpha (Marketing Review Solution).